Results 1 to 10 of 10
  1. #1
    Hi TwoBrutal,

    Been registered here for a while, but not posted.

    Some of you know me already (Gazza_DJ on IMOC and MR2OC, SonicSW20 on Instagram, Gareth in real life...) - I helped organise Japfest this year and last year with Dan.

    A lot of this is copied from IMOC, so apologies for any odd formatting issues!

    Previously I had a Rev4 Sonic Shadow, which unfortuantely got rear ended at traffic lights. I had this car for nearly 4 years, done 60,000 miles in it, and visited all corners of the UK from Cornwall to the Outer Hebrides. I'd grown quite attached to it to be honest. R310YKP (or Royksopp, as my friend called it) served me well.

    As I got Royksopp:



    I soon learnt a valuable lesson in wet weather greasy road handling:



    But I fixed it:



    I went on many an aventure with it:







    Saw some pretty amazing places:



    And as it was my daily, I made it work for whatever I needed it for:



    And as I received it yesterday:



    While it doesn't look like much, the rear alignment was way out, an engine or gearbox mount is broken / damaged, and the rear of boot is crumpled. Also, one of the T tops doesn't fit the same as it used to - it's much tighter to the point where it's quite difficult to lock it in place so unfortunately it's got somewhat twisted. Definitely not suitable to go back on the road, anyway.

    So, the Rev 5! Purchased back in October 2014.

    Here's some pictures from original the ad:











    First step was to fit some of the aftermarket bits from the Rev4 - Janspeed exhaust and Momo Team wheel:

    Momo Team wheel fitted:



    Small, I know. I later replaced this with an OMP Corsica.



    Next step was to replace the tired suspension, so it got some BC coilovers. I also got the 16inch Advans repaired (crack in lip) and refurbed in Silver / dark grey:




    That's next to a car at stock height for comparison.

    Advans:




    At some point during all this, I picked up a Legalis R comically cheap, but it's a turbo box with an NA reducer / flange on it. Sounds great but is quite loud.



    What's better than staggered 16inch Advan SA3's?



    staggered 17inch Advan SA3's with polished lips, of course! They came up for a great price in the right fitment for an MR2, with tyres that were usable too. NIce to be able to switch the look up now and then.







    Did my first track day in the car back in December 2015. Great fun, only casualty was the alternator, seemed to have died from the heat.

    Oh, this was the start of the end of the clutch as well... Car was due a cambelt etc soon too so the plan was to drop everything and do the clutch at the same time.

    I worked out my MPG for the morning session - ~14MPG!

    Anyway, here's some track day photos:







    And a short clip of a little slide on the exit of Agostini:

    https://www.youtube.com/watch?v=IiWmCuiSESQ

    The previously mentioned OMP Corsica went on around Jan 2016:





    Roll onto March 2016... It's time to undertake the biggest DIY project yet for me. When referring to us, I mean myself and a couple of able friends :)

    Not a lot of photos of this, more time was spent cracking on and getting it done.

    Saturday morning was spent getting the engine out of the car. In about 3hrs, we had this:



    Not bad going! A few bolts took a bit of doing to get off, nothing too unexpected for an old car.

    First job was timing side. None of us have done this before. We also replaced the crankshaft seal, hardest bit was getting the old one out without damaging the oil pump housing, it's a tight fit! Got that sorted though, good thing too as the existing one had started to leak.

    We installed brand new tensioner pulleys and water pump. To be honest the old water pump was fine - it was completely clean on the inside. Bearing was a little noisy, but would probably have been fine for a long while yet.

    Took a couple of attempts to get the belt on in the correct position, but we got there in the end. Barred the engine over a few times to double check, and it was lining up with where it was before.

    Few tidying up jobs etc and preparation for clutch tomorrow (starter motor out etc), and that was Saturday done. Big thank you to Stu and Dom for all the hard work :th:

    Onto Sunday - clutch change. Just me and Stu today. Again, neither of us had done this before so the learning curve was steep. We've done our research though, and had copies of the BGB and engine manuals to hand.

    Took a bit of doing to get the gearbox off the block. Some persuasion with a rubber mallet and giving it a good wiggle around to free it off the dowels and it was off.

    The old release bearing was noisy and felt pretty loose. Definitely didn't have much life in it! The inside of the housing was absolutely filthy (old friction material?):



    Cleaned up the components, applied grease where required, and installed the new release bearing. Also installed two new driveshaft seals as this is the perfect time to do it.

    Onto the clutch itself. No drama here really, removed the old one, which was pretty much dead. worn down to within a fraction of a mm to the rivets:





    It was definitely on borrowed time!

    We also replaced the crankshaft oil seal on this side.

    Replaced the clutch with a standard Exedy OE replacement clutch. No need for anything fancy on an NA.





    Rest of the day was spent getting things ready to go back in the car. Replacing the ARB bushes as the existing ones were a mess (thanks to Dom for the bushes). Got a poly engine mount to go in as well. Ran out of time on the Sunday, but had it all back together and working perfectly the following Saturday.

  2. #2
    Not sure what happened.... must have edited my OP with the this reply rather than replying? Anyway!

    Bit of a ramble to follow....

    Had a long weekend up in Norfolk with Henry and John (bank holiday weekend March 2016). One of Henry's friends owns a boat restoration business on The Broads, and very kindly made some room for us to work on our cars. We all had our own list of things to do, some were more extensive than others. The big ones were John's cambelt, and Henry's polybushes. Polybushing is easy, I hear you say! Well yeah, but ask anyone who's worked on Henry's suspension components (Stu/Dom!) and you'll understand... That car does not like being taken apart.

    I just had a 22mm Ultra Racing front ARB to fit, and a few cosmetic bits and pieces, most of my time was for helping Henry and John with theirs.

    Day 1 (friday) went well, nothing to report really. We had time so we took our time with preparing everything. a solid 10/10 day all round really.

    Day 2 shit on us from a great height. To start off with, my rear window exploded on the way to the workshop in the morning. A van going the other way flicked up a stone, and it went through my window like a bullet:





    Obviously it's completely fucked, so Henry kindly delayed work on his one to help me get the window out with as little mess as possible. Surprisingly we barely dropped any on the floor, and there wasn't that much in the car either. John cracked on with getting access to his cambelt, and I was going over to assist when needed as I've done a cambelt with the engine out of the car.

    Much tape was used (didn't have any duct tape annoyingly):



    And getting as much of the sealant off as we could:



    The problem we have now is obvious - It's Saturday on the easter weekend, we're our in the sticks in a workshop on the Norfolk Broads, my car has no rear window, and storm Katie was due to blow over our way very soon. This is probably a good point to mention that moods were already rather sour all round - the jubilee clip on Henry's coolant temperature plate failed just as we arrived at the workshop so it dumped a good few litres of coolant on the floor, and anyone who's DIY'ed a cambelt in situ knows how easily that job will ruin your mood...

    My luck did turn though. A few messages via Facebook sourced two rear windows in breaker cars within 30 minutes of the workshop. Result! The tricky bit is getting them out in one piece. Fortunately Danny Sayer put me in contact with Chris at Hank Windscreen Specialists, who came out first thing on Easter Sunday to remove a breaker rear window (took him about 10 minutes to do, absolute pro!), and came and fitted it to my car, and only charged me �70 for his services.

    So, Henry's polybushes. We started with the front end. As mentioned previously, this car does not like being taken apart. True to form, the tension rod bolts were not coming free. Breaker bar plus heat wouldn't shift it, liberal applications of plusgas wouldn't shift it, a 450nm electric impact wouldn't shift it, and an air impact that's happy to dismantle boats wouldn't shift it.
    So, we removed the tension rod brackets so we could get them in the vice and really have a go at them. At one point we had an 7ft long extension on the breaker bar. We bent the breaker bar.
    It's not going well. But wait, there's more! When I was putting the tension rod bracket bolts back in the car by a few threads so we don't lose them, I discovered that the captive nut for one of the front bolts had failed - there was no thread in there at all! The spot welds had failed and it was rolling around on the chassis rail.

    An annoying job has now become a serious problem, as this captive nut is located in a cavity with no access.

    We now have a car we cannot bolt one of the tension rod brackets back on to safely, and tension rods that we cannot get free of their brackets, with old bushes that are now ruined due to all the heat cycling.

    A few solutions were proposed for the captive nut problem - Option 1 - cut through the front firewall, fix the captive nut. Option 2 - replace the captive nut with a stud, weld that in. Option 3 - cut a larger hole, and weld a nut in from below.

    Option 1 is ugly, but means we don't touch the chassis rail, which is structural, and is really the 'proper' fix. Option 2 is a good alternative as we don't have to cut anything. Option 3 means cutting the chassis rail, which we weren't keen on.

    Henry decided to go option 1:



    No rotational force is applied to it, so it will be OK just torqued up correctly - Henry will get getting it spot welded in place and a plate over the hole as soon as possible though.

    That's one problem fixed. The brackets were still an issue though. In the end, we sourced some replacement brackets from Stu and just cut the tension rods out of the old brackets.


    With the new brackets on Henry's, the front end was finally back together.



    Moving onto the rear end, it wasn't having it. Heat, breaker bar, electric and air impact guns could not move the control arm to subframe bolt. As we didn't have a spare subframe, we decided to leave it there. Henry went to Stu's on wednesday to get it sorted with a replacement subframe. They had to cut the old subframe up to get the arms out!

    Meanwhile, over at Camp Goodwood Green:



    John has access to his cambelt! Lots of things slowed us down here. First off, the crank pulley bolt was ridiculously tight. On my car, and the breaker engine Stu and I practiced on, the pulley bolt came of with a couple of pulses with an impact gun, no problem. John's wasn't having it. In the end we did the starter motor trick, where we cranked the engine with the EFI fuse removed, with an impact socket and a breaker bar against the floor to crack the nut off. Other issues included stubborn timing cover bolts (only M6's so you have to be careful with them), and a lot of swearing getting the engine hanger free with the car in situ. What didn't help is that the guide we were following was missing some steps, and the BGB assumes you've got the engine out of the car.

    Anyway, after much swearing and some blood sacrafices, we had the belt on. Barred it over a couple times, and the intake cam is a tooth out. At this point there was a, erm, enthusiastic exhange between myself and John. Essentially, we were both trying to do it in a different way. John had marked the belt with match marks which is great for making sure the belt goes on in the right place, but and once you bar the engine over these are going to take an age to come back round exactly due to the pulley ratios as it's a DOHC engine with two pumps driven off the belt. The only bit that matters is that the cam marks and pulley all align up again at cyl1 TDC once you've barred it over 720 degrees. At this point, any match marks you've made on the belt won't come round in the same place.
    2nd attempt at getting it lined up was spot on though, and the car fired up first time once we had it back together enough to test it. This just left John to put it back together (with assistance from me and Henry where required).

    This is the setup we were working in:



    It's was so nice to actually have some space, light, and shelter while working!

    The location was lovely as well:



    At some point during all of this, I fitted a 22mm Ultra Racing front ARB. Nothing to report here - it was the only thing that went with no drama I think!

    Finally, on Tuesday morning, we had all the cars back on the road (after a 2am finish the night before). Mine is running really nicely - turns out it's actually got a bit of ignition advance dialled in at about 12-13 degrees, which may explain why it seems a bit quicker than most NA's.
    Henry's is running much nicer with stronger boost now - he must have had a slight boost leak before as the only thing he's done in that area is take off all the boost piping and the throttle body to change the valve cover gasket. Sounds so naughty now with the turbo flutter, which it wasn't doing before. Handles much nicer now as well, just needs an alignment.
    John's is running well after the cambelt change, engine sounds happier and is firing up better due to a cleaned out throttle body and IACV. He's got a pulsing/whistling noise under load at higher revs, which can only be a slight leak on the exhaust or possible intake - he fitted a new downpipe, and all the ACIS and top half of the intake manifold had been off while changing the valve cover gasket, shouldn't take too long to isolate and fix. Will be spot on then!

    So, a very long weekend, and I'd certainly had enough at points, as had John and Henry. Enjoyed it overall though, even though I was pretty broken on Tuesday morning!

    Anyway, after all that, I enjoyed the car as a daily with no real drama. Some time late 2016, I took delivery of this:



    More to follow soon :D

  3. #3
    The engine had a rebuild (OEM pistons and rings, new bearings, new valve seals etc) around 8-9 years ago, made good compression and otherwise ran well, so the plan here is to just clean it up and replace all the external seals and gaskets. Needs to be stripped down to the longblock for that of course!







    [img]]http://i.imgur.com/IhJd0Zm.jpg[/img]



    Making things look pretty:



    And partially assembled to get an idea of the look and make a decision on whether to buy red or black hoses:



    As part of the refresh program, I’m also replacing the water pump / timing stuff, and the oil pump, which of course means sump off. Needed removing anyway as whoever put this thing together before using waaaaaay too much RTV. Annoyingly they used sealant on every other fucking gasket on the engine, none of which actually need additional sealant. The amount of sealant used on the oil pump was ridiculous, there was sealant *in* some of the oil ways.

    Oil strainer did it's job fortunately:



    4 of the 6 sump baffle bolts and threads were all chewed up. 1 of them looked like this:



    . Underneath that was a snapped bolt. What should be relatively simple / easy jobs are becoming much longer than they need to be because of shortcuts / mistakes of whoever has been here before. Annoying, but better to find this stuff out before installation.

    Hydraulic tensioner threads mostly came out with the bolt (I did relieve the force on the tensioner before undoing them) so I can only assume they were way over torqued. Fortunately Machine Mart had coil kits in stock:

    Fucked:



    Unfucked (did the bottom too as it was pretty shitty as well):



    Sorted out the sump baffle bolt as well, photo with the test bolt in place:



    Starting to look more like a proper engine again now! Downpipe is a BRD item. Quality / fitment seems really decent.



    Had to coil several of the exhaust manifold studs as well, not got any photos of that as I just cracked on.

    Mr. RTV was at it again on the turbo water fitting. Doesn’t seem to be any sign of a gasket here at all!



    With everything cleaned up and OEM gaskets installed, it was looking more complete:



    As you can see, I decided on red hoses :)

  4. #4
    When you summarise it like this you realise how much effort has gone into this car over the years

  5. #5
    Quote Originally Posted by gavsdavs View Post
    When you summarise it like this you realise how much effort has gone into this car over the years
    Just remember to never add up the costs!

  6. #6
    Meanwhile, the car was still being used as a daily. There was a week or two in June 2017 where everything just went wrong.

    First, I had to rob the thermostat from the turbo engine to fit to mine as it was stuck open -



    Next up, rear left puncture. Annoying as it wasn't that long ago I had to replace the other side due to pothole damage. The other side still had a good 6mm left on it and I don't like having mismatched tyres across an axle so I had to source another Ultrac Sessanta which has now been discontinued. Remaining stock is a little more expensive than it was! Managed to find one with a manufacture date of mid 2016 so all good for now.



    I have a proper spare too -





    Then only a week or so later as it just never ends, disaster struck again -



    So that wasn't fun.

    Fortunately I was most of the way to work anyway so let it cool off a bit and limped it to work rather than leave it where it was and later fight the PCN I would have no doubt have gotten while waiting for recovery! Got a bit hot but didn't overheat.

    Mr. AA man arrived, and we did the 'we've got to try and put it on the back of the van' dance, but it just wasn't going to happen. Front wheels on the ground meant the splitter was scraping the floor, rear wheels on the ground (which I didn't really want them to do anyway) wasn't going to happen either -



    So a proper truck was called -



    And we're on the way to the driveway.



    New radiator is a Japspeed item that lots of people seem to resell under various names -



    And I wouldn't recommend it. Fitment to the car is fine, but the stock fan simply doesn't fit without modification, and once the radiator pipes were on I could no longer open the top bleed screw!

    Fitment on the Stoney rad pipes wasn’t amazing either, but next day delivery was available so in this situation they’ll do.

    There was still some drips under the car but they're coming from the undertrays near the front ARB and further back. It seems unlikely that the hard pipes around the fuel tank went at the same time (spoiler alert - they did), and when one of the Stoney radiator pipes was leaking I didn't notice at first as it was travelling along the hard line and accumulating in the frunk, and then onto the undertrays.

    After removing undertrays and checking, I could see it was coming down from above the fuel tank. This was now Late June / early July so heater wasn’t needed and conversion was imminent so the lines got plugged as a get it through the next month or so bodge:



    Annoying, but tank is coming out anyway for changing the fuel pump so it’ll get sorted then.

    Roll onto mid September. Engine is ready, final bits like getting the flywheel machined done, checklist of stuff that needs doing is been run through again to make sure nothing has been missed… It was time. Not got many photos of the whole process but being a 3SGTE conversion there’s nothing special happening here, its a bolt in swap!

    Being a Rev5 it has ABS, the donor did not. To retain ABS, I used a pair of ABS rear hub carriers and got the Turbo hubs pressed into them with new bearings. One of the turbo driveshafts had an ABS ring on it already for some reason, so I only had to remove the ABS ring from one other shaft and install it on the non ABS shaft. Delicate job but a little bit of heat and a few tappy tap taps did the job.

    At some point during all this the tank was dropped, Walbro pump was installed, and the hard line was fixed so I had a working heater again.

    The engine was in mechanically!





    A huge thank you Luke Bliss (RIP dude) - he spent a good 40 mins or so on the phone running through the wiring with me - saved me a huge amount of time if I bumbled through it myself. With his help it fired up first time. Rather than swapping out the fuse box and fuse box to passenger footwell loom, I just repinned the body plug at the ECU end.

    So it's nearly there! There were a few issues to sort - couple leaks to isolate, huge leak from the flexi on the mongoose exhaust (damaged in transit), and some other bits, but it was nearly there!

  7. #7
    With the teething issues sorted, it was back on the road! Visited my nan in North Yorkshire, always a nice time. Car is a bit too low for some of the roads… Lost an undertray and damaged an arch liner on this one:

    https://streamable.com/1ydqt

    Went over Buttertubs as well. Taking it quite easy as it's wet, and I don't know the road very well. Lots of corners you cannot see around:

    https://streamable.com/xch90

    Obligatory photo stop:



    All seemed to be running well and surprisingly efficient. From Birchanger Services on the A120/M11 to Catterick Garrison, it did 38MPG. Mind you, once I was in the Dales it did about 20MPG so…

    Of course, there’s always *something*. Oil consumption had been a little high but not excessive. Something to keep an eye on anyway.

    That something to keep an eye on soon turned into visible smoke when off throttle (rarely under load), which eventually turned into smoke on idle on hot starts only. Sounding rather like turbo seal failure. Compression and leak down test were both good.

    So turbo off - oh dear.

    https://streamable.com/htzf7

    It did have a little bit of play prior to installation, but it didn’t seem like that much. In hindsight I should have just got it rebuilt at the time, but there we go.

    I replaced it with a Mamba CT26 hybrid for a while, despite getting good reviews from MR2 and Celica owners, I couldn’t get it to work right - no matter what I did with actuator adjustment etc, it overboosted to the point of reaching fuel cut.



    When removing the original turbo, I realised that despite saying CT26 on the compressor housing, it definitely wasn’t an “ordinary” CT26 hybrid. The turbine housing was not a stock Toyota turbine housing. Some research and asking people on Facebook groups later, it turns out the turbo was a Turbo Technics S148. Due to the issues with the Mamba turbo, I got the S148 rebuild and installed it again.

    With that whole saga sorted, I could enjoy the car again:



    Yep, it’s winter now!

    Ran it for a while, still on daily duties until I moved closer to work in late Feb. With 176k on the clock, it’s earned a break from daily use I think.

    Took it to Brands Hatch in May, which was good fun.

    Wrong line, but sideways is fun:
    https://streamable.com/c066f









    Quick stop on the way back from an Ace Cafe meet for a cool photo:



    As always, the work list keeps on growing at the same rate stuff is ticked off.

    Booked in next month for sills / underbody maintenance repair. Hoping underbody is just surface that needs cleaning up, and then get the whole thing sealed up.

    Changed the brake pads to Porterfield R4S. So far they seem excellent. Of course, I wasn't going to get away with doing any job scot-free - my rear left coilover has blown it's guts out. Never ends!

    Coilover replacement, ball joints, tie rod ends, and polybushes added to the list.

    More money into the pit!

  8. #8
    July 2018 - Sills chopped off - worse in there than expected. Also the rear arches weren’t too solid on the drivers side after some poking.





    Welding and painting is way above my skill level, so a local shop did the work.

    Sill status: Fixed.





    Wallet status: dead.

    I also picked up a single Recaro SR3 confetti pattern for cheap. Needed a new bolster and base foam, and a deep clean.



    I think the stock seats are more comfortable, but this is so much more supportive and keeps you in the seat much better.

    With it back gother again there’s always time for a couple photos after a drive:





    Which brings us up to where we’re at now.



    Managed to crossthread a ball joint mounting hole annoyingly which stopped proceedings. Have the bits to fix it now, looking like next weekend due to weather I think. May get a couple hours in after work this week perhaps.

  9. #9
    It is nice to see a car mantained with nice fresh bits.
    Not cheap to live with, but good to see nonetheless :)

  10. #10
    All back together for a while now. Not without problems of course....
    Here are my nice freshly passivated and coated front tension rods. A pair of right hand side ones! :lol:



    Had to go and get the one off the car coated which wasn't very cost effective!

    On the modification front, something I've been wanting to do for a while... Oil temperature, oil pressure, and AFR gauges:



    Sensors etc not wired in, have all the bits to do it now. Building up to it! (I hate wiring).

    MOT ran out early September, had to cancel my original booking date due to windscreen replacement issues. Still, couple weeks mid september we were in for an MOT:



    Passed, no advisories!

    Went for a morning run with the MR2 guys on the last Sunday of September, was a great time as always!

    Geometry feels good, perhaps a little on the safe side. Tyres are clearly the weak link now - Kumho KU31. Fine as a mid range tyre for daily duties which is what the car was primarily doing before (I didn't fancy buying 2-3 sets of AD08R's a year!) but now it really needs something with a bit more sticktivity on the tarmac. Bit of research needed, but I think 0 toe or even a little bit of toe out up front could work well.

    Anyway, on Sunday we had 2x 3SGTE SW20's, 1x 2GRFE Supercharged SW20, 1x 1MZFE SW20, 1x 1MZFE Supercharged AW11, and 1x 4AGZE AW11.

    The Supercharged V6 AW11 sounds absolutely ridiculous, the whine is just amazing. Need to get some videos of it.












Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •